No announcement yet.

Aurora Fans with Asus ROG Strix Z370-G Motherboard

  • Filter
  • Time
  • Show
Clear All
new posts

  • Aurora Fans with Asus ROG Strix Z370-G Motherboard

    I started to build my second PC and realized my Asus ROG Strix Z370-G Motherboard does not have an RGB Header. I decided to go with the Aurora fans and their controller. They all lit up and worked fine on the first boot up prior to installing Windows 10. Once I installed Windows and all of my software I noticed they were no long lighting up but were still running. I downloaded the app to try and control the LEDs, but keep getting an error "NOT GET DEVICE" when I open the Aurora app.

    Any thoughts on how to fix this?

    Thanks in advance.

  • #2

    According to the situation, we suggest you to check if the in/out part connect correctly. And also the USB-4 pin wire connect to Motherboard USB header.

    If the fans still cannot light up, please let us know.


    • #3
      Thanks for your response.

      I have double checked all of the wires and they appear to be connected properly. As I mentioned above, all fans and lights lit up properly prior to installing an operating system. Once I installed Windows 10 they stopped working. I downloaded the app and I receive the error "NOT GET DEVICE".


      • #4

        We understand your situation. We have to make sure all the wires connect correctly before discussing software problem.
        We tested the Aurora Fan and Window 10, and the fan operated well. So we suggest you:
        1. Go to Device Manager to check if your USB input device detects VID: FF01 & PID: 0207 on your computer.
        2. If your computer does not detect the device. Please recheck your USB wire connection on the motherboard, or change other USB headers.
        3. Please try to reinstall the software, before that, remove the old one.
        4. If all the steps aren’t work, please mail your details and fan-controller photos to We suppose the reason of the issue could be wire or controller problem. We will have our sales representative to contact you soon.


        • #5
          I switched to an Asus motherboard with an RGB header and had no issues using Asus's Aura software.

          I did not change the way the fans were connected so it must have been something with the software or controller, but it works great now. Thanks.